import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\s*Hello.*world";
final String string = "test 1\n"
+ "Hello\n"
+ "foo\n"
+ "bar\n"
+ "a better world\n"
+ "foo\n"
+ "bar\n"
+ "world\n"
+ "test 2";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}