use strict;
my $str = 'test 1
Hello
foo
bar
a better world
foo
bar
world
test 2';
my $regex = qr/(?s)\s*Hello.*world/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";