package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)\s*Hello.*world`)
var str = `test 1
Hello
foo
bar
a better world
foo
bar
world
test 2`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}