package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?|^\s*(\p{S}).*$|^.*(\p{S})\s*$|^.*?(\p{L}{1,6})\s*$)`)
var str = `$19.99
19.99
19.99 EUR
19.99$ CAD
19.99 E
19.99 $
$ 19.99
$ 19.99 USD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}