const regex = /(?|^\s*(\p{S}).*$|^.*(\p{S})\s*$|^.*?(\p{L}{1,6})\s*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?|^\\s*(\\p{S}).*$|^.*(\\p{S})\\s*$|^.*?(\\p{L}{1,6})\\s*$)', 'gm')
const str = `\$19.99
19.99
19.99 EUR
19.99\$ CAD
19.99 E
19.99 \$
\$ 19.99
\$ 19.99 USD`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}