import re
regex = re.compile(r"(?|^\s*(\p{S}).*$|^.*(\p{S})\s*$|^.*?(\p{L}{1,6})\s*$)", flags=re.MULTILINE)
test_str = ("$19.99\n"
"19.99\n"
"19.99 EUR\n"
"19.99$ CAD\n"
"19.99 E\n"
"19.99 $\n"
"$ 19.99\n"
"$ 19.99 USD")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")