use strict;
my $str = '$19.99
19.99
19.99 EUR
19.99$ CAD
19.99 E
19.99 $
$ 19.99
$ 19.99 USD';
my $regex = qr/(?|^\s*(\p{S}).*$|^.*(\p{S})\s*$|^.*?(\p{L}{1,6})\s*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}