import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|^\\s*(\\p{S}).*$|^.*(\\p{S})\\s*$|^.*?(\\p{L}{1,6})\\s*$)";
final String string = "$19.99\n"
+ "19.99\n"
+ "19.99 EUR\n"
+ "19.99$ CAD\n"
+ "19.99 E\n"
+ "19.99 $\n"
+ "$ 19.99\n"
+ "$ 19.99 USD";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}