re = /(?|^\s*(\p{S}).*$|^.*(\p{S})\s*$|^.*?(\p{L}{1,6})\s*$)/m
str = '$19.99
19.99
19.99 EUR
19.99$ CAD
19.99 E
19.99 $
$ 19.99
$ 19.99 USD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end