// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?|^\s*(\p{S}).*$|^.*(\p{S})\s*$|^.*?(\p{L}{1,6})\s*$)").unwrap();
let string = "$19.99
19.99
19.99 EUR
19.99$ CAD
19.99 E
19.99 $
$ 19.99
$ 19.99 USD";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}