using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"CUT-FROM-.*CUT-TO";
string input = @"CUT-FROM-A ...
CUT-FROM-B ...
CUT-TO ...
CUT-TO
abc
CUT-FROM-C ...
CUT-TO
def
";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}