// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)CUT-FROM-.*CUT-TO").unwrap();
let string = "CUT-FROM-A ...
CUT-FROM-B ...
CUT-TO ...
CUT-TO
abc
CUT-FROM-C ...
CUT-TO
def
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}