$re = '/CUT-FROM-.*CUT-TO/s';
$str = 'CUT-FROM-A ...
CUT-FROM-B ...
CUT-TO ...
CUT-TO
abc
CUT-FROM-C ...
CUT-TO
def
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);