import re
regex = re.compile(r"CUT-FROM-.*CUT-TO", flags=re.DOTALL)
test_str = ("CUT-FROM-A ...\n"
"CUT-FROM-B ...\n"
"CUT-TO ...\n"
"CUT-TO\n"
"abc\n"
"CUT-FROM-C ...\n"
"CUT-TO\n"
"def\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")