import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "CUT-FROM-.*CUT-TO";
final String string = "CUT-FROM-A ...\n"
+ "CUT-FROM-B ...\n"
+ "CUT-TO ...\n"
+ "CUT-TO\n"
+ "abc\n"
+ "CUT-FROM-C ...\n"
+ "CUT-TO\n"
+ "def\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}