package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)CUT-FROM-.*CUT-TO`)
var str = `CUT-FROM-A ...
CUT-FROM-B ...
CUT-TO ...
CUT-TO
abc
CUT-FROM-C ...
CUT-TO
def
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}