# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=')\b|\b(?=')/%/g;t' <<< "'whatever'
hello 'world'               hello '%world%'
'foo' bar                   '%foo%' bar
'foo bar'                   '%foo bar%'
foo 'bar' but gar 'har'     foo '%bar%' but gar '%har%'"