const regex = /(?<=')\b|\b(?=')/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\')\\b|\\b(?=\')', 'g')
const str = `'whatever'
hello 'world' hello '%world%'
'foo' bar '%foo%' bar
'foo bar' '%foo bar%'
foo 'bar' but gar 'har' foo '%bar%' but gar '%har%'`;
const subst = `%`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);