import Foundation
let pattern = #"(?<=')\b|\b(?=')"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
'whatever'
hello 'world' hello '%world%'
'foo' bar '%foo%' bar
'foo bar' '%foo bar%'
foo 'bar' but gar 'har' foo '%bar%' but gar '%har%'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"%"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)