$re = '/(?<=\')\b|\b(?=\')/';
$str = '\'whatever\'
hello \'world\' hello \'%world%\'
\'foo\' bar \'%foo%\' bar
\'foo bar\' \'%foo bar%\'
foo \'bar\' but gar \'har\' foo \'%bar%\' but gar \'%har%\'';
$subst = "%";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;