use strict;
my $str = '\'whatever\'
hello \'world\' hello \'%world%\'
\'foo\' bar \'%foo%\' bar
\'foo bar\' \'%foo bar%\'
foo \'bar\' but gar \'har\' foo \'%bar%\' but gar \'%har%\'';
my $regex = qr/(?<=')\b|\b(?=')/p;
my $subst = '%';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";