using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=')\b|\b(?=')";
string substitution = @"%";
string input = @"'whatever'
hello 'world' hello '%world%'
'foo' bar '%foo%' bar
'foo bar' '%foo bar%'
foo 'bar' but gar 'har' foo '%bar%' but gar '%har%'";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}