re = /(?<=')\b|\b(?=')/
str = '\'whatever\'
hello \'world\' hello \'%world%\'
\'foo\' bar \'%foo%\' bar
\'foo bar\' \'%foo bar%\'
foo \'bar\' but gar \'har\' foo \'%bar%\' but gar \'%har%\''
subst = '%'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result