#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=')\b|\b(?=')"
Local $sString = "'whatever'" & @CRLF & _
"hello 'world' hello '%world%'" & @CRLF & _
"'foo' bar '%foo%' bar" & @CRLF & _
"'foo bar' '%foo bar%'" & @CRLF & _
"foo 'bar' but gar 'har' foo '%bar%' but gar '%har%'"
Local $sSubst = "%"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)