# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.+\R(.+)/$1/gm;t' <<< "Paragraph 1 Line 1
Paragraph 1 Line 2
Paragraph 1 Line 3
Paragraph 1 Line 4
Paragraph 1 Line 5
Paragraph 1 Line 6
Paragraph 2 Line 1
Paragraph 2 Line 2
Paragraph 2 Line 3
Paragraph 2 Line 4
Paragraph 2 Line 5
Paragraph 2 Line 6"