use strict;
my $str = 'Paragraph 1 Line 1
Paragraph 1 Line 2
Paragraph 1 Line 3
Paragraph 1 Line 4
Paragraph 1 Line 5
Paragraph 1 Line 6
Paragraph 2 Line 1
Paragraph 2 Line 2
Paragraph 2 Line 3
Paragraph 2 Line 4
Paragraph 2 Line 5
Paragraph 2 Line 6';
my $regex = qr/^.+\R(.+)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";