#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.+\R(.+)"
Local $sString = "Paragraph 1 Line 1" & @CRLF & _
"Paragraph 1 Line 2" & @CRLF & _
"Paragraph 1 Line 3" & @CRLF & _
"Paragraph 1 Line 4" & @CRLF & _
"Paragraph 1 Line 5" & @CRLF & _
"Paragraph 1 Line 6" & @CRLF & _
"" & @CRLF & _
"Paragraph 2 Line 1" & @CRLF & _
"Paragraph 2 Line 2" & @CRLF & _
"Paragraph 2 Line 3" & @CRLF & _
"Paragraph 2 Line 4" & @CRLF & _
"Paragraph 2 Line 5" & @CRLF & _
"Paragraph 2 Line 6"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)