import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.+\\R(.+)";
final String string = "Paragraph 1 Line 1\n"
+ "Paragraph 1 Line 2\n"
+ "Paragraph 1 Line 3\n"
+ "Paragraph 1 Line 4\n"
+ "Paragraph 1 Line 5\n"
+ "Paragraph 1 Line 6\n\n"
+ "Paragraph 2 Line 1\n"
+ "Paragraph 2 Line 2\n"
+ "Paragraph 2 Line 3\n"
+ "Paragraph 2 Line 4\n"
+ "Paragraph 2 Line 5\n"
+ "Paragraph 2 Line 6";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}