# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.+\R(.+)"
test_str = ("Paragraph 1 Line 1\n"
"Paragraph 1 Line 2\n"
"Paragraph 1 Line 3\n"
"Paragraph 1 Line 4\n"
"Paragraph 1 Line 5\n"
"Paragraph 1 Line 6\n\n"
"Paragraph 2 Line 1\n"
"Paragraph 2 Line 2\n"
"Paragraph 2 Line 3\n"
"Paragraph 2 Line 4\n"
"Paragraph 2 Line 5\n"
"Paragraph 2 Line 6")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.