#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)([\p{Hiragana}\p{Katakana}\p{Han}]+)"
Local $sString = "[DMSM-8433] 加護亜依 Kago Ai – 加護亜依 vs. FRIDAY"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")