import re
regex = re.compile(r"([\p{Hiragana}\p{Katakana}\p{Han}]+)", flags=re.UNICODE)
test_str = "[DMSM-8433] 加護亜依 Kago Ai – 加護亜依 vs. FRIDAY"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")