re = /([\p{Hiragana}\p{Katakana}\p{Han}]+)/
str = '[DMSM-8433] 加護亜依 Kago Ai – 加護亜依 vs. FRIDAY'
# Print the match result
str.match(re) do |match|
puts match.to_s
end