package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\p{Hiragana}\p{Katakana}\p{Han}]+)`)
var str = `[DMSM-8433] 加護亜依 Kago Ai – 加護亜依 vs. FRIDAY`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}