using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\p{Hiragana}\p{Katakana}\p{Han}]+)";
string input = @"[DMSM-8433] 加護亜依 Kago Ai – 加護亜依 vs. FRIDAY";
RegexOptions options = RegexOptions.CultureInvariant;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}