// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)([\p{Hiragana}\p{Katakana}\p{Han}]+)").unwrap();
let string = "[DMSM-8433] 加護亜依 Kago Ai – 加護亜依 vs. FRIDAY";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}