const regex = /([\p{Hiragana}\p{Katakana}\p{Han}]+)/u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\p{Hiragana}\\p{Katakana}\\p{Han}]+)', 'u')
const str = `[DMSM-8433] 加護亜依 Kago Ai – 加護亜依 vs. FRIDAY`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}