use strict;
my $str = '“@joemcelderry91: I\'ve woken up with the flu I think! :( gunna try and run it off haha!! X†get well soon joey :)';
my $regex = qr/[“â€"]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";