#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bv(\d+\.)+\d+\b"
Local $sString = "ABCDEF v3.4.2 GHI KLMN" & @CRLF & _
"ABCDEF v33.44.222 GHI KLMN" & @CRLF & _
"ABCDEF v3.4.2.1 GHI KLMN" & @CRLF & _
"DoNotv3.4.2CaptureThis" & @CRLF & _
"Do-v3.4.2-CaptureThis"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")