import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bv(\\d+\\.)+\\d+\\b";
final String string = "ABCDEF v3.4.2 GHI KLMN\n"
+ "ABCDEF v33.44.222 GHI KLMN\n"
+ "ABCDEF v3.4.2.1 GHI KLMN\n"
+ "DoNotv3.4.2CaptureThis\n"
+ "Do-v3.4.2-CaptureThis";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}