// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bv(\d+\.)+\d+\b").unwrap();
let string = "ABCDEF v3.4.2 GHI KLMN
ABCDEF v33.44.222 GHI KLMN
ABCDEF v3.4.2.1 GHI KLMN
DoNotv3.4.2CaptureThis
Do-v3.4.2-CaptureThis";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}