import re
regex = re.compile(r"\bv(\d+\.)+\d+\b")
test_str = ("ABCDEF v3.4.2 GHI KLMN\n"
"ABCDEF v33.44.222 GHI KLMN\n"
"ABCDEF v3.4.2.1 GHI KLMN\n"
"DoNotv3.4.2CaptureThis\n"
"Do-v3.4.2-CaptureThis")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")