const regex = /\bv(\d+\.)+\d+\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bv(\\d+\\.)+\\d+\\b', 'g')
const str = `ABCDEF v3.4.2 GHI KLMN
ABCDEF v33.44.222 GHI KLMN
ABCDEF v3.4.2.1 GHI KLMN
DoNotv3.4.2CaptureThis
Do-v3.4.2-CaptureThis`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}