import Foundation
let pattern = #"\bv(\d+\.)+\d+\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ABCDEF v3.4.2 GHI KLMN
ABCDEF v33.44.222 GHI KLMN
ABCDEF v3.4.2.1 GHI KLMN
DoNotv3.4.2CaptureThis
Do-v3.4.2-CaptureThis
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)