re = /\bv(\d+\.)+\d+\b/
str = 'ABCDEF v3.4.2 GHI KLMN
ABCDEF v33.44.222 GHI KLMN
ABCDEF v3.4.2.1 GHI KLMN
DoNotv3.4.2CaptureThis
Do-v3.4.2-CaptureThis'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end