# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Hello there|\G(?!\A)) *\K\S/x/gm;t' <<< "Hello there Cory Klein
Have fun
Hello there Samantha Rodgers"