import Foundation
let pattern = #"(Hello there|\G(?!\A)) *\K\S"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hello there Cory Klein
Have fun
Hello there Samantha Rodgers
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"x"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)