#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(Hello there|\G(?!\A)) *\K\S"
Local $sString = "Hello there Cory Klein" & @CRLF & _
"Have fun" & @CRLF & _
"Hello there Samantha Rodgers"
Local $sSubst = "x"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)