re = /(Hello there|\G(?!\A)) *\K\S/m
str = 'Hello there Cory Klein
Have fun
Hello there Samantha Rodgers'
subst = 'x'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result