use strict;
my $str = 'Hello there Cory Klein
Have fun
Hello there Samantha Rodgers';
my $regex = qr/(Hello there|\G(?!\A)) *\K\S/mp;
my $subst = 'x';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";