using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Hello there|\G(?!\A)) *\K\S";
string substitution = @"x";
string input = @"Hello there Cory Klein
Have fun
Hello there Samantha Rodgers";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}